Friday, February 10, 2006

"Please help me figure this out!"

Yesterday was quite a challenge for me, but my problem started well before yesterday.

My husband and I live in an apartment complex in which the manager resists doing anything for anyone, so I knew from the get-go that this was going to be a challenge.

Tuesday morning, I went next door to the manager's office (yes, he's one door over), and told him that my refrigerator was not working and that I needed to get it fixed before my food started going bad. He told me he would call the owner to see what he wanted to do. I gave him all day and never heard anything.

Wednesday morning, I went back to the office and asked the manager if he'd gotten in touch with the owner yet because my food was beginning to spoil. He said he'd tried to reach him and wasn't able to, but would keep trying. I didn't hear anything the rest of that day, either.

Thursday morning, just before 9 a.m., I decided to bypass the manager and called the owner at his workplace and told him that my refrigerator was not working, that I'd told the manager about it two days before and reminded him the day before, and that nothing had been done and I was doing what I could to keep my food from going bad. (I put most of it in bags in my truck because it was about 30 degrees outside.) He said, "I'll be there in about 10 or 15 minutes."

The owner showed up about 20 minutes later with the apartment manager, and told me that he had called an appliance repair shop and that they would have someone over that day sometime. At about 9:35 a.m., the repair shop van pulled in, and my fridge was fixed by 10:45 a.m. I waited a couple of hours and then put my food back in my fridge.

Then, sometime around 12:30 p.m., my Internet connection crashed on me. But it wasn't just the Internet I couldn't access. My husband and I got Vonage for our home phone service, and in order to use it, you have to have a broadband Internet connection, so when I lost that Internet connection, I had no phone. This was a serious problem.

I thought the problem was with my cable Internet provider, so I called. According to their readings, I had a secure connection. They told me that it could be a problem with my Vonage service: maybe since they share bandwidth, my router was overwhelmed. So I was told to call Vonage and see if there was something they could do and if the problem was on their end.

I was on the phone with a Vonage service tech who barely spoke English for almost an hour. He had me connecting and disconnecting, unplugging and plugging things back in. At one point, I got a dial tone on my phone, but I had no way to connect to the Internet from my computer. In the end, the Vonage rep told me the problem was not on their end, but maybe there was a problem with my Apple Airport Extreme (which serves as a wireless Internet router), and suggested I call Apple.

For about 20 minutes, I was on the phone with an Apple service tech. He had me switch a few wires around to no avail, and finally suggested I unplug and turn everything off for about five minutes. When I plugged everything back in and got them up and running, my Internet connection was back on and I had a dial tone on my phone.

I never did figure out what was wrong in the first place! I made my call to the cable company around 1:30 p.m., which is when I noticed the outtage, and didn't get the problem fixed until after 3 p.m. I still don't know what the problem was.

The good parts of yesterday were, though, that my sister decided she wants to rejoin Mary Kay and be my recruit, and I had a good session with my beginning ASL students at church last night.

And tonight, our church is hosting "A Night of Love and Laughter" to celebrate Valentine's Day, and a nice couple from our church bought tickets for us so we could go! So we're going! Yea! Maybe I'll tell you about it tomorrow. Stay tuned!

2 comments:

Tonya said...

Yea for me!!! I'm glad I made your day!!!

Devona said...

When our internet goes down (which is a about once every 3 or 4 months) I can usually get it back up just by turning off my coputer for a few minutes. Kind of like what worked for you.

I don't know why that fixes it, but it works every time.